In sonarqube 8.4.1 developer, there is no java plugin

Hi support team,

  • versions used (SonarQube, Scanner, Plugin, and any relevant extension)
    8.4.1 developer

  • error observed (wrap logs/code around triple quote ``` for proper formatting)
    there is no java plugin

  • steps to reproduce
    Login to sonarqube > Go to Administrator > click Market > enter Java > there is no java language plugin

Refer to this capture sonarqube_not_found_java_plugin|690x365

Could you please check and give me support this issue?



Welcome to the community!

Java’s there in my copy. :slight_smile:

Where are you looking and/or what makes you think it’s missing? Have you tried re-exploding the zip file?


Hi G Ann Campbell,

I am using image in repository: sonarqube and tag: 8.4.1-developer.

I would like to answer your question:

  • Where are you looking -> Answer: As I sent step reproduce and the capture in the previous comment. I could try to answer again: Login to sonarqube > Go to Administrator > click Market place > enter Java in search box > there is no java language plugin. The capture for search java language plugin in

  • Expectation: Result for search java language plugin should include Java Code Quality and SecurityLanguages Code Analyzer for Java even it works well for version 8.3.1-developer.

  • Work around: I find work around way by manual install plugin however I do not think it is nice way and it should be installed from Market place instead.

For the question ‘Have you tried re-exploding the zip file?’ -> Could you please explain which zip file you mean?


Hi @Uyen ,

let me just jump in for a minute here :wave:

it was not really clear that you were using a docker installation, but it is now. can you show us how you started the docker image (compose or docker run command)? did you define the plugin directory as a volume with the plugins that you already had in the previous version?

i have just started a fresh sonarqube:8.4.1-developer instance and can see the java plugins as expected, so i assume that the error could be in the local filesystem

1 Like

Hi Tobias,

Thank you for feedback.

I am using helm chart and deploy to kubernetes and use below command to install sonarqube.

$ helm install stable/sonarqube --namespace sonarqube

I could install successfully with another plugin such as SonarJS and I could see it in folder extensions/plugins/. For now we did not define the plugin directory as a volume.

bash-5.0# ls -la
total 28276
drwx------ 3 sonarqub sonarqub 192 Aug 13 10:40 .
drwx------ 1 sonarqub sonarqub 42 Aug 13 10:07 …
-rw-r–r-- 1 sonarqub sonarqub 19648 Aug 13 10:12 sonar-jacoco-plugin-
-rw-r–r-- 1 sonarqub sonarqub 10073594 Aug 13 10:11 sonar-javascript-plugin-
-rw-r–r-- 1 sonarqub sonarqub 5746 Aug 13 10:11 sonar-typescript-plugin-
drwx------ 2 sonarqub sonarqub 6 Aug 13 10:07 tmp


Ah okay so you are running within k8s. this is currently one of the few environments that is not supported by sonar and plugins are one of the reasons for that :sweat_smile:

apart from that i assume that you are using the helm chart from this repository where it is listed as deprecated by the helm people. There is another community maintained helm chart that looks rather promising, so maybe you have more luck with this one :slight_smile:

1 Like

Hi Tobias,

Yes, thank you for your feedback and the suggestion.

Actually because it already works for 8.3.1-developer so I would still use it for newer version. May be for next upgrade I am going to check new repository.

Thank you so much for quick feedback and support!


1 Like