Implementing SonarQube into Azure DevOps CI Pipeline

Hi there, I’m totally new to SonarQube, I’m trying to implement SonarQube to my CI pipeline on azure DevOps. Everything is working as expected, except when running the Run Analysis Task. I don’t know if anyone have experience in DevOps and Pipeline but I’m really stuck here. Here’s what I’m using:

Anyone have an idea about how to solve this issue please?

Greetings @mhmd_mshymsh,
I would start by removing the plugin comunitybsl or upgrade the java version on the azure node if required by the plugin.

Also new hand having trouble integrating into a AzureDevops CI pipeline. Latest correspondence in this thread:


No I solved it out, the issue was in the existing JDK on Microsoft Hosted Agent.

  1. Uploading JDK Zip folder to Azure Blob Storage
  2. Using Java Tool Installer Task to install the JDK from Azure
  3. Run the Analysis Code normally

Everything then worked fine for me, the pipeline was successfully finished and the result was publish to our SonarQube Server