How to handle "Re-run SonarQube Scanner using the -X switch to enable full debug logging" Error

Dear Expert,

I’m totally new at SonarQube.
We’ve suddenly got the SonarQube Error on CI/CD pipeline, Concourse today. Since we had no change around sonar properties recently, we have no idea except for reboot SonarQube docker or just skip the SonarQube Check so far.

Is there any workaround for this issue, please advise me.
Thank you in advance.

Error Message (Include environment info) :

Preparing SonarQube scanner...
Starting sonar-scanner (type: cli)...
INFO: Scanner configuration file: /opt/sonar-scanner/conf/
INFO: Project root configuration file: /tmp/build/put/sonar-input/
INFO: SonarQube Scanner
INFO: Java 1.8.0_151 Oracle Corporation (64-bit)
INFO: Linux 4.15.0-159-generic amd64
INFO: User cache: /root/.sonar/cache
INFO: SonarQube server 7.9.1
INFO: Default locale: "en_US", source code encoding: "UTF-8" (analysis is platform dependent)
WARN: SonarScanner will require Java 11+ to run starting in SonarQube 8.x
INFO: Sensor SurefireSensor [java] (done) | time=70ms
INFO: Sensor JavaXmlSensor [java]
INFO: Sensor JavaXmlSensor [java] (done) | time=3ms
INFO: Sensor HTML [web]
INFO: Sensor HTML [web] (done) | time=14ms
INFO: ------------- Run sensors on project
INFO: Sensor Zero Coverage Sensor
INFO: Sensor Zero Coverage Sensor (done) | time=4ms
INFO: Sensor Java CPD Block Indexer
INFO: Sensor Java CPD Block Indexer (done) | time=81ms
INFO: 55 files had no CPD blocks
INFO: Calculating CPD for 44 files
INFO: CPD calculation finished
INFO: Analysis report generated in 91ms, dir size=696 KB
INFO: Analysis report compressed in 319ms, zip size=316 KB
INFO: ------------------------------------------------------------------------
INFO: ------------------------------------------------------------------------
INFO: Total time: 18.928s
INFO: Final Memory: 32M/995M
INFO: ------------------------------------------------------------------------
ERROR: Error during SonarQube Scanner execution
ERROR: The 'report' parameter is missing
ERROR: Re-run SonarQube Scanner using the -X switch to enable full debug logging.
ERROR in /opt/resource/out : line 251 with exit code 2

Thanks to following discussion, we understood that caused by the lack of disk spaces. After clean-up, it worked fine in our case. Thank you.

Error: The ‘report’ parameter is missing

– Faced similar issue, and found disk space issue on the server. Once clearing the disk space it worked.

Sonarqube : The ‘report’ parameter is missing

–I just had the same problem here: my Linux server ran out of disk space and Sonarqube started to produce the report parameter is missing error. After deleting some unused files and restarting sonarqube, everything worked normal again

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.