How to debug why sonercloud not reporting to azureDevOps

Hi,
I am facing with problems sonar Cloud (Developer Edition) not reporting quality gate back to AzureDevOps. Whatever I try status is always in waiting.
image

I’ve tried regenerating PAT, removing and re-adding status check,… But nothing seems to work. PAT has permissions on Code: Read&Write. A few weeks ago PR decoration worked, but not anymore.

So my question is, is there a way to debug why sonarcloud.io is not reporting back SonarCloud quality gate?

Thank you

Hi @tadejcek,

Can you share your latest background task id? There is no easy way to debug what the problem may be. It is usually connected with PAT, but if you already regenerated it, there may be some other problem. Once you provide me with the background task id, I can check few things, to determine where the problem lies.

Best,
Marcin

Hi Marcin,

thank you with your quick response. Background ID is AXdDUp3GvjsbjIt4xXRR

Tadej

Hi @tadejcek,

Can you tell me what properties do you set (just the properties, not the values) when executing sonar-scanner and how do you run analysis?

Would it be feasible for you to re-run the analysis and provide me the new background task id?

Best,
Marcin

Hey I’m having the same issue. I’ve regenerated and still not passing it back to the PR. Here is the background ID AXdEZUfy005Z9CeORUqM

Hi @wamcubs,

Is it feasible for you to rerun the analysis, and provide me the latest background ID?

Best,
Marcin

Yep. Give me a second and i’ll get it. Thanks

AXdEh0Bc005Z9CeORUqm

Hi @wamcubs,

I reached to you in the private thread.

Best,
Marcin

Hi Marcin,

background ID: AXdEhRniZbXE7bhWaUua

Requested propeties:

-Dsonar.organization
-Dsonar.projectKey
-Dsonar.projectVersion
-Dsonar.sources
-Dsonar.host.url
-Dsonar.sourceEncoding
-Dsonar.exclusions
-Dsonar.login
-Dsonar.c.file.suffixes
-Dsonar.cpp.file.suffixes
-Dsonar.objc.file.suffixes
-Dsonar.eslint.reportPaths
-Dsonar.nodejs.executable
-Dsonar.pullrequest.key
-Dsonar.pullrequest.branch
-Dsonar.pullrequest.base
-Dsonar.pullrequest.provider
-Dsonar.pullrequest.vsts.instanceUrl
-Dsonar.pullrequest.vsts.project
-Dsonar.pullrequest.vsts.repository
-Dsonar.scm.disable
-Dsonar.scm.provider

Hi @Marcin_Majewski,

any news on my case.

Thank you
Tadej

Hi @tadejcek,

Can I ask if sonar.scm.disable is set to true or false? And what scm.provider do you use? There is usually no need to set them. Auto-detection of scm provider will work if the root directory of your project contains .git or .svn. The same goes with sonar.scm.disable, there is no need to use this property.

Best,
Marcin

Hi,

oh, my bed I found where the issue lay.
1.) sonar.scm.disabled was true
2.) sonar.scm.provider had typo

Sorry for wasting your time and many thank for helping me out!

Stay healthy and safe
Best,
Tadej

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.