How can I bring back rule-check after accidentilly exclude it using Idea's context menu?

  • Operating system: Mac
  • IDE name and flavor/env: Intellj
  • SonarLint plugin version:
  • Is connected mode used: No

And a thorough description of the problem / question: As the title

Hello and welcome to the community!

You can open the Settings then Tools > SonarLint, go to the Rules tab, find the language for which you disabled the rule and tick the box for the rule you disabled. Modified rules appear in blue so it will help you find which one differs from the defaults.

If you never modified/enabled/disabled any other rule, you could also click on the Restore Defaults button.

Hope this helps

1 Like