Helm deployment for sonar 8.5

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
  • what are you trying to achieve
  • what have you tried so far to achieve this

Hi Guys,

Did anyine face issue with helm chart deployment of sonar with 8.5 version. If we are using external postgresql database it is saying unable to conmect to database. The setup works fine with 8.4. can you pls help me?

Hello @Brighty_Sara_Babu,

Without a more detailed description of what you tried and what does not work we unfortunately can’t help.
Can you clarify the problem ?

Olivier

1 Like

We have pulled the helm chart from GitHub and deployed with azure managed postgresql with sonarqube version 8.3 and8.4. it works fine. But, whenc we try to do the same with sonarqube 8.5. it is not working. It is giving an error “failc to connect to the database”. , But if I use postgresql false and using the container database spun with the sonarqube It works fine. Let me know if you need more details

Please send the details of how you deploy the SonarQube docker image (I am not and helm chart expert) add a zip of the SonarQube logs directory

We are pulling the image from dockerhub using docker pull sonarqube:8.5.1-enterprise and deploying it using the command below.

Helm upgrade --install sonar stable/sonarqube --set postgresql.enabled=true --set database.type=postgresql --set postgresql.postgresqlserver=servername --set postgresql.postgresqlusername=username --set postgresql,postgresqlpasswors=password --set postgresql.postgresqldatabae=database --set image.tag=8.5.1-enterprise

Attaching the error logs

That helm command does not tell me anything because I don’t know how helm works (and this is not officially in the scope of what we support).
And a screenshot of the logs is no good for me. I need the full logs in text format.

You can find more details of sonarqube deployment using helm here. The kubernetes deployment won’t comeup if there are any prestartup failures. So the only error in the log is fail to connect to database

Sorry but here you are reversing the approach. You’re asking me to read helm documentation to be able to help you. This is something I cannot do. This is not supported at the moment.
I expect you to provide me what I ask you to be able to investigate.

Do yo guys officially support kubernetes deployment?

I have provided you all the logs I have and the way we deploy it. What else details you need from me?

I hope my request is fair.

Have attached the logs in text format

Hello,

Thanks for the logs. There’s nothing obvious about why it’s not working (except that the postgres connection can’t be established). We should follow another track I think.
Now if you refer back to you reference to the helm chart you’re using you should notice some that hints that it’s not a reliable one. When one reads :warning:(OBSOLETE) as the first words of the description, this should raise an alarm, don’t you think ?

This might be related to the usage of Azure Database for PostgreSQL. There are a few other threads which suggest that gssEncMode is not currently supported by Azure Postgres and should be disabled, specifically around the upgrade to SonarQube 8.5.

2 Likes

Yeah thanks guys. Disabling gssencMode worked for 8.5 as well as 8.6. thanks a lot.

Thanks Alan

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.