Github members/teams aren't synced

In this page:

foobar means obfuscated organization name

It seems like a new feature “Now your members can be automatically synchronized with your GitHub organization.” doesn’t work properly.
I made to switch “Automatic sync with GitHub” many times, and I still see this tip and it switched to “Manual” again
Also I don’t see any Github teams to set permissions (general + template)

And welcome to the community!

I just tried to reproduce your issue on some of my organizations but I wasn’t able to. Everything seems to work fine on my end.

Do you see any error in your browser’s developer tools ? Console errors or network errors ?


I don’t see any failed requests in browser’s console, and this tip appear again ~5 min after switch to “Github” and this setting switched again to “Manual”. Also I don’t find any github groups from our org in github to set permission for default permissions template.

Thanks for looking


We were able to find the root cause, without going into the details it comes from a race condition in our WS calls. So when you refresh, when you are lucky you will see the correct UI and when you are not you will see the “Manual” one.

I created this ticket to fix the issue: SCCOMM-10

To clarify the issue with permissions and permissions template, currently we only synchronize the members and not the teams/groupe. So you won’t see your Github teams synchronized in SonarCloud. But we do have plans to work on synchronizing groups and permissions at some point.

What would you expect to see in the permissions and permissions template ? Do you already have some specific expectations regarding synchronization of groups and permissions ?

1 Like

Do you already have some specific expectations regarding synchronization of groups and permissions

We have Github team for systems engineers, so it would be better to have all permissions for new repo to this team, and would be configured once. Now we have to add members to permissions manually.

Thanks for explanation, will looking to fix and this new Github group feature.

1 Like


I can’t enable Github member synchronization either.
I tried many many times to enable it, but it’s always back to “Manual” when reloading the page.
Github members don’t appear in the member list even after a while.

SCCOMM-10 suggests this is a UI issue, but it looks like the sync is really not enabled.

Actually, maybe I did not understand the feature properly.
Seems like users connecting to SonarCloud for the first time are automatically added to the organization as members and get access to the right projects based on their permissions in Github.
I expected all users from Github to be imported in the member list once I activated the sync.