Failing analysis ID: "AXD5nK1uUTs7Qql32UDd"

Template for a good new topic, formatted with Markdown:

  • ALM used (GitHub, Bitbucket Cloud, Azure DevOps)
    GitHub
  • CI system used (Bitbucket Cloud, Azure DevOps, Travis CI, Circle CI
    GitHub
  • Scanner command used when applicable (private details masked)
  • Languages of the repository
    javascript
  • Only if the SonarCloud project is public, the URL
    • And if you need help with pull request decoration, then the URL to the PR too
  • Error observed (wrap logs/code around with triple quotes ``` for proper formatting)
    No errors in background tasks
  • Steps to reproduce
    Push to repo
  • Potential workaround
    None

Welcome to the community!

I see the following error in our logs:

ERROR: SCM provider was set to “github” but no SCM provider found for this key. Supported SCM providers are hg,git

It would appear you have set SCM provider to “github”, which is not a valid SCM provider, and unnecessary when using Autoscan. Please drop the setting, and let me know if this fixes your issue.

Hi Janos,

Thanks for the quick reply.
When I go to Administration -> General Settings -> SCM the field is blank.
How can I unset the value or drop the setting?

Daniel

Do you set it in a .sonarcloud.properties file in the repository?

No. This is the content of the file :

sonar.scanner.appVersion=3.2.0.1227
# Required metadata
sonar.projectKey=corpo-nodeJS-kpi
sonar.projectName=corpo-nodeJS-kpi
# Comma-separated paths to directories with sources (required)
sonar.sources=src
sonar.exclusions=**/node_modules/**
#sonar.tests=test
sonar.test.inclusions=**/*.test.js

# Coverage results path
sonar.javascript.lcov.reportPaths=coverage/lcov.info
sonar.coverage.exclusions=**/__tests__/**,**/__mocks__/**

# Language
sonar.language=js

# Encoding of the source files
sonar.sourceEncoding=UTF-8

Also, whenever I set a value in any field of the general settings, I get this message :
Validation failed. An error has occurred. Please contact your administrator

Thanks, I can now edit the various settings.
It looks like the organization did not have an administrator!