Failed to upload report: Fail to request url


We are using Sonarqube community version with open JDK 11

in recent times, our Jenkins builds are failing with the following error with no major changes from our side

we checked the web.logs and couldn’t find anything related. and this build was working fine till last week and now we are intermittently facing the below errors.

[ERROR] Failed to execute goal org.sonarsource.scanner.maven:sonar-maven-plugin: (default-cli) on project ffm: Failed to upload report: Fail to request url: timeout: Socket closed -> [Help 1] 
**12:54:38** [ERROR] 
**12:54:38** [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch. 
**12:54:38** [ERROR] Re-run Maven using the -X switch to enable full debug logging.

can someone help with this?

notes: This build usually runs for a longer time around one hour which was working fine and suddenly we are facing the above error, we tried to use Jenkins nodes with a higher instance type and still it looks the same . would like to know what could be the reason for this .


There is likely something on your network, e.g. a proxy, that’s blocking the analysis report submission because your project has gotten larger, which results in a larger analysis report submission, which has crossed an allowed-size threshold. You should check with your network folks.

:warning: Make sure you upgrade to SonarQube v9.9 LTS soon, not only to benefit from our Best LTS Ever™, but because soon we will systematically ask users to upgrade when they ask questions about earlier versions of SonarQube, which are now considered unsupported. :smiley:



we already checked with our network folks about proxy stuff,we don’t have any restrictions to block larger report submissions, this issue popped up recently and we also tried to reduce report size ( Analysis report compressed in 12500ms, zip size=44.1 MB ) which also does not fix the issue.

from sonarqube logs -

access log - just gives get request information
ce.log -gives logs like below

2023.06.02 09:26:50 INFO ce[AYhzN8799O14N7K6tpkr][o.s.c.t.CeWorkerImpl] Executed task | project=FFM_sparta_AYdMzKGO1lkkK8u7rjt6:test_sparta | type=REPORT | id=AYhzN8799O14N7K6tpkr | submitter=nicholas-walton93171 | status=FAILED | time=4301415ms

can you suggest a better way to debug and fix this issue ?


My only suggestion is to look to your network. SonarQube doesn’t limit the upload size or duration. The FAILED message you found in ce.log is unrelated to the analysis-side error you’re seeing, since on the analysis side, you didn’t succeed in submitting the report and on the CE side what you’re seeing is a report that was submitted but errored-out in processing.