Error receiving the submodules in Azure Devops

Hi There!

We try to evaluate SonarCloud with Azure Devops for our projects.
Our Codebase is on Bitbucket. It is a C++/Qt project with submodules.
(I have other Questions regarding the use of Qt projects, but I will split them in different topics).

So I created a SonarCloud pipeline, and on the “Get sources” step, I checked “Checkout submodules”.

The normal checkout runs good - but for the Submodules I get the “Host key verification failed” error and of course nothing is checked out.

Maybe someone can point me to something I missed - although I think this should be straight forward.

I also tried to do this from a custom bash element - but got the same error.

Thanks in advance!

Hey there.

That’s probably a better question for Azure DevOps/Bitbucket than for this community – SonarCloud “just” analyzes sources, we don’t care how you get them into your pipeline. It’s not git. :slight_smile:

(I assume you’re trying to pull sources from Bitbucket into Azure Devops?)