Error about unsupported higher version of TypeScript

Hi!

Output form sonar scanner says:

WARN: You are using version of TypeScript 4.1.3 which is not officially supported; supported versions >=3.2.1 <3.8.0
ERROR: Failed to analyze file [src/api-client.ts]: Cannot read property ‘map’ of undefined

Is it a known issue or we need to consider upgrading something?

Versions used:

  • SonarQube Developer Edition version 8.4.2 (build 36762)
  • SonarScanner: 3.3.0.1492
    Plugins:
  • SonarTS 2.1 (build 4359)
  • SonarJS 6.2.1 (build 12157)

Hello @Valeriia_Iuzhakova,

What’s happening here is that your source code is using some features of TypeScript 4.x that SonarJS is not able to parse for the moment. On that note, we are actually in the middle of upgrading our parsers and introducing the support of TypeScript 4. These changes will be part of SonarJS 7.2 release scheduled for next week.

Long story short, it is a known issue, but you will have to upgrade your SonarQube to 8.7 once available. which should be very soon.

Best,
Yassin

Thank you for making everything clear @Yassin_Kammoun! This information is very valuable for us.

Best,
Valeriia