Documentation lists the incorrect compatible version of TypeScript

  • SonarQube v7.9.3
  • The documentation for v7.9 states that Sonar is compatible with version 2.2 of TypeScript. Based on my experience with v7.9.3 that is incorrect.
  • Open this URL https://docs.sonarqube.org/7.9/analysis/languages/typescript/ run a Sonar scan on v7.9.3 and you can observe that the docs say:
    Supported Frameworks and Versions TypeScript >= 2.2
  • Run a SonarQube scan on this version and observe the error which disagrees with the docs:
    [ERROR] You are using version of TypeScript 3.1.6 which is not supported; supported versions >=3.2.1
  • I have installed a compatible version of TypeScript for the analysis stage and now it works. (This feels very wrong though.)

I tracked down why this is happening:

1 Like

Hi @shanew,

SQ 7.9.3 includes version 5.2.1 of JS/TS analyzer. You claim that you have 6.2.1 installed, that means you updated it manually from the market place.
As for SQ 7.9.x versions, documentation for the languages is static and does not depend on the installed versions of the analyzers, so you see doc for JS/TS analyzer 5.2.1. That’s unfortunate limitation we have for LTS version. So I’m afraid we can’t do anything here, sorry for the inconvenience.

Ok, thanks for the context.

(Our instance is managed at a company level so I had no idea someone manually installed SonarJS 6.2.1 after the upgrade to Sonar v7.9.3.)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.