Disable (or hide) login with credentials 10.4

Must-share information (formatted with Markdown):

  • what are you trying to achieve
    We are using SSO to login into our Sonarqube, and until Sonarqube 10.3 version, the login page showed the following:
    image

Even though if you clicked on More option, the default “Login with credentials” showed, it was nice that it was “hidden” as default.
Starting with 10.4, that is no longer happening, and it shows the two options by default, like the following:

Is there an option to disable the “Log in with credentials” section?
I even tried setting sonar.forceAuthentication to false, but the two options are still being there.

Thank you very much for your support.

Regards, Cristian.

Hey there.

It’s not possible to disable this (and honestly, I’m happy about that, otherwise I’ll be spending a lot of time pointing users to the backdoor login when they accidentally lose admin access and can’t find the link in the docs).

That said, since it’s a recent change, we’ll keep listening for feedback about it.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.