Different issues with the same plugin on the same files

Hi everyone,

I’ve recently come ot the end of the development of a plugin. I tried to cold deploy it on my company’s version of SonarQube, however for some reason it seems SonarQube doesn’t raise the same issues on both instances (local (8.3) or company (7.2)). I have tried with different versions locally, compiling the plugin with different versions of Java, and using it with different versions on SonarQube, but I never seem to get the same issues that I get on the company server.

The only difference left is that the company SonarQube runs on Linux while mine runs on Windows. Is it possible that the OS difference brings such difference in the analysis ?

Thanks in advance.


What’s the difference in the issues that are raised? Could this have something to do with whether/how you detect line endings?


Hi Ann,

Thanks for your answer. It turns out that’s what it was ! I fixed the issue late last night. I’m leaving the post up in order for anyone that has the same problem to see the solution.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.