cpp.analyzer.Analyzer$AnalyzerException: Exit code != 0

I am also getting the same crash but slightly different stack trace on Fedora 33 and Windows 10 after being forced to update to the latest version. Was working without issue before the update. Can you share the results / fix ASAP?

04:33:50.992 ERROR: Exception in thread pool-3-thread-7
com.sonar.cpp.analyzer.Analyzer$AnalyzerException: Exit code != 0: C:\dev\src\project\src\ComponentManagerV2.cpp
    at com.sonar.cpp.analyzer.Subprocess.execute(Subprocess.java:81)
    at com.sonar.cpp.analyzer.Subprocess.execute(Subprocess.java:78)
    at com.sonar.cpp.plugin.CFamilySensor.lambda$process$8(CFamilySensor.java:655)
    at com.sonar.cpp.analyzer.AnalysisExecutor.lambda$submit$0(AnalysisExecutor.java:59)
    at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)
    at java.base/java.util.concurrent.FutureTask.run(Unknown Source)
    at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.base/java.lang.Thread.run(Unknown Source)

Currently unable to use SonarCloud at all for C++ it seems. Have tried in two different projects, and all cpp source files crash with the same error.


what version of CFamily analyzer fo you have installed in your SonarQube server?

Hi Massimo… I am using Sonar cloud. I received a message saying I had to update versions, so installed the latest wrapper and scanner.

INFO: SonarScanner
INFO: Java 11.0.3 AdoptOpenJDK (64-bit)
INFO: Linux 5.10.21-200.fc33.x86_64 amd64
INFO: Analyzing on SonarCloud
INFO: Default locale: "en_US", source code encoding: "UTF-8" (analysis is platform dependent)
INFO: Load global settings
INFO: Load global settings (done) | time=944ms
INFO: Server id: 1BD809FA-AWHW8ct9-T_TB3XqouNu

Hi @seghcder ,

ok, thanks for the info. FYI it is recommended to always download the wrapper, each analysis.

Would you be able to share the sonar-cfamily-reproducer.zip file? I can send you a PM if you prefer to do it privately.

Thanks - please send pm :slight_smile:

Hi @seghcder ,

I sent you a pm.

Hi @seghcder ,

You are facing CPP-2696, you can avoid it by defining ASIO_DISABLE_NOEXCEPT in your build.

Ok that seems to have worked. I don’t use Boost but the Rest Server library we use uses ASIO. Thanks for the help.

1 Like

Hi @seghcder ,

ok, thanks you for the information, we plan to solve the issue on our side.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.