Coverage report is getting generated, but unable to see coverage

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
  • how is SonarQube deployed: zip, Docker, Helm
  • what are you trying to achieve
  • what have you tried so far to achieve this

Do not share screenshots of logs – share the text itself (bonus points for being well-formatted)!
07:29:52.736 DEBUG: Using pattern ‘**/cov_reports/coverage.xml*’ to find reports

07:29:52.787 INFO: Python test coverage

07:29:52.802 INFO: Parsing report ‘/home/desjensl/jenkins_slave/metamodeling-jenkins/vihlaslave73/workspace/mm_feature_pytest_coverage_reqmm/cov_reports/coverage.xml’

07:29:52.947 ERROR: Cannot resolve the file path ‘_testenv/system/certifi/certifi-2018.1.18-py3.6.egg/certifi/init.py’ of the coverage report, the file does not exist in all ‘source’.

07:29:53.075 ERROR: Cannot resolve 267 file paths, ignoring coverage measures for those files

Is there any way to fix this?
For backstory, I got a code coverage with same error on one build and when i reran the build I was not getting any coverage but both build had same warning

Hi,

Welcome to the community!

There is a mismatch between the paths in your coverage report and the paths that analysis sees. You’re going to have to resolve that.

 
Ann