CLion analysis blocks other functionality

Please provide

  • Operating system:

Ubuntu 23.04

  • SonarLint plugin version:


  • Programming language you’re coding in:


  • Is connected mode used:

No. I just installed the plugin and started experimenting with it.

And a thorough description of the problem / question:

I tried the plug in the past and was giving it another try. I’m working on a source file with 5029 LOC. Whenever I type a character, I get the message “Running SonarLint Analysis for xxxx.cpp”.

I timed it with a stopwatch, which takes 1:06 minutes to run. It does run in the background so it doesn’t block the IDE, but the plugin itself is blocked and any other functionality is unresponsive while it runs the analysis on the file.

So if I click on “Show Rule Description ‘cpp:Sxxxx’” on some warning, it shows nothing until the analysis is complete. If I wait for one minute and fix the issue, then it’s one more minute to be able to find out if the fix did it.

I tried disabling automatic mode but that didn’t help much as I still have to wait for another minute to check if the solution worked. It actually made things worse because the warnings I get are out of date.

This means I can’t see any useful feedback unless I haven’t typed anything in the last 1:06 minutes. Is there a know solution to this?

Hello @alandefreitas,

Thanks for raising this problem. I created this ticket to fix the issue. I will try to fix it for the release that should happen next week.

In the meantime, as a workaround if you select the issue in the Current File view the description will be displayed.

Hope this helped, let us know if you encounter other issues