CI Analysis page redirects users before being able to copy the access token

Using SonarCloud with GitHub and GitHub Pipelines

Steps to reproduce:

  • Analyze a new private project from GitHub
  • Go to Analysis Method (Administration > Analysis Method)
  • [IMPORTANT] Toggle off the “SonarCloud Automatic Analysis” option.
  • Click any “Follow the tutorial” link on the Supported Analysis Methods below

The screen with the instructions shows up then immediately redirects you into the project’s home page.
There are no logs on the browser’s console and no 301 responses over the network

Potential workaround:
If you click on the link while the “SonarCloud Automatic Analysis” is toggled ON, the page works as expected

Affected platforms:
We were able to reproduce the bug consistently using
Google chrome 88.0.4324.150 on MacOs Catalina 10.15.7
Firefox Developer 86.0b8 on Fedora 33 (KDE)

Other information:
I haven’t tested any public repositories.
Our account is new. It’s still on the trial, although there is a credit card associated with it.
We have another account using Bitbucket and Bitbucket Pipelines and it works as expected.
We are currently migrating our repositories from Bitbucket to Github, all repositories already had working pipelines on Bitbucket.
We don’t use the sonar-project.properties file.
All the repositories we tried so far had the Automatic Analysis enabled by default.

Hello @Bruno_Rafael,

Thanks for reporting this bug, I can confirm it is a bug.
I would like to get more details of you use case, like at which step of the creation of the project in Sonarcloud did you disable the Automatic analysis ? Was it right after creating the project and before the first Autoscan analysis finished or was it after you already received a successful or failed analysis? Could you also provide me the name of your project ?

Thanks for your answers.

Have a nice day
Amélie

1 Like

We were able to reproduce the bug with our applications that had automatic analysis recommended by default. The only application so far that didn’t have the automatic analysis recommended by default was not affected.
Right after the project had been analyzed for the first time, if we tried to change the analysis method we would hit the bug.
As far as I am aware all of the projects within our organization (loft-br) that have the automatic analysis recommended by default are affected.
The last project I tested has the key loft-br_community-web

Thanks @Bruno_Rafael for your answer and for the precious details.
We have taken into account the bug and we will fix it.

Have a nice day.
Amélie

This bug is hindering our progress. When can we expect the fix?