CERT_HAS_EXPIRED - Azure Pipelines

  • Version: SonarCloudPublish@1
  • Server: Microsoft Hosted Agent (windows-latest)

It was working before, it’s not e new project.

Logs:

Starting: Publish SonarCloud analysis
==============================================================================
Task         : Publish Quality Gate Result
Description  : Publish SonarCloud's Quality Gate result on the Azure Pipelines build result. To be used after the actual analysis.
Version      : 1.9.0
Author       : sonarsource
Help         : [More Information](http://redirect.sonarsource.com/doc/install-configure-scanner-tfs-ts.html)
==============================================================================
##[error][SQ] Could not fetch metrics
##[error][SQ] API GET '/api/metrics/search' failed, error was: {"code":"CERT_HAS_EXPIRED"}
##[error][SQ] API GET '/api/server/version' failed, error was: {"code":"CERT_HAS_EXPIRED"}
Finishing: Publish SonarCloud analysis
5 Likes

Blocking me this morning too.

With the Java 11 issue and this, it’s been a rough week for the sonarcloud task.

2 Likes

Hey all.

Thanks for the report. It has been escalated internally.

Colin

2 Likes

We are also getting the same error in all builds. Please resolve ASAP. Below errors for Database project using .Net.

##[error][SQ] Could not fetch metrics

##[error][SQ] API GET ‘/api/metrics/search’ failed, error was: {“code”:“CERT_HAS_EXPIRED”}

##[error][SQ] API GET ‘/api/server/version’ failed, error was: {“code”:“CERT_HAS_EXPIRED”}

Hey all,

Thanks for letting us know about the issue. It seems to be isolated to the Publish Quality Gate Result step. Teams are still investigating, and for now if you’re affected I would advise you to temporarily disable that step. Analyses should still be sent to SonarCloud and processed.

Thanks for your understanding.

Colin

We have the same issues with many other domains and curl. They share a CA certificate that has expired. Browsers seems to be fine right now but command line tools like curl and openssl are reporting errors.

Hi @anderssonjohan,

You may want to look at this page. I do not have a repro for the curl issue, but my OS and patching level might differ. The page before suggests that up to date systems should work correctly.

2 Likes

Thank you, I found that page and also got pointers to old software. I thought I used the latest version of curl but I did not. I used the bundled version from macos (7.54 in my case) and not the one I installed using Homebrew. Using 7.67 or 7.70 fixes this bug.

1 Like

Hello. Im having the same problem. I think this is causing Prepare Analysis task to fail (SonarCloudPrepare task) when running it with “Integrate with MSBuild”

Hi @Andreas_Lefkatis, @sumanthkr, @SamSmithNZ, @eduherminio, @anderssonjohan
We have re-generated our certificate to eliminate the offending expired root certificate.
This should fix the issue. Let me know!
Thanks!

2 Likes

Hi Alex, it’s working now. Just tried some pipelines and the task “Publish Quality Gate Result” completes with success. Thank you.

Thank you. What was the cause, and how will you prevent this from happening it again?

Thank you very much for solving the issue over the weekend. I really appreciate it otherwise it would have caused lot of work for us.

Hi Sam. This was the cause.

1 Like

Thanks for the solving the issue.

I can also confirm the fix, thanks @AlxO.

10 posts were split to a new topic: CERT_HAS_EXPIRED issue on SonarQube

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.