Can't set permissions for newly created group

web

(dexter) #1

Dear Sonar guys,

As an admin I created a new group in Sonar but I cannot set its permissions because it does not appear in “Security -> Global permissions”.

I see the group in the “Security -> Groups” page.

How can I adjust the new group’s permissions ?

Thanks


(Julien Lancelot) #2

Hi,

Groups that have no permission doesn’t appear in the “all” of the permission’s page.
You need either to click on the “Groups” tab or to enter the name of your group in the search bar.

Regards,
Julien Lancelot


(dexter) #3

Thank you, that did it. But I find this not obvious. Even if the group has no permissions set, it should appear with all checkboxes unchecked.

Regards.


(dexter) #4

Back to this again,

I created a group which has the permission “create projects” and I added a user to it. When this user logs in, it cannot create a new project. Could you tell me what I missed ?

Thanks


(Julien Lancelot) #5

For the moment, it’s a known issue that it’s not possible to create a project from the UI when having only this permission.
But it’s still possible to use a web service : https://next.sonarqube.com/sonarqube/web_api/api/projects/create

Regards,
Julien Lancelot


(Julien Lancelot) #6

In fact this issue has been fixed in SonarQube 7.6.


(dexter) #7

Ok thank you.