Can't get SonarLint Connected Mode set up in VSCode

sonarlint
vscode

(Inna Nill) #1

I have the latest versions of VSCode (1.27) and SonarLint (1.5.0).
I have SonarQube 6.7.4.

In VSCode, I tried to set up connected mode via going to User Settings and adding the following line into my settings.json on the right hand side:
“sonarlint.connectedMode.servers”: [{ “serverId”: my_server_id", “serverUrl”: “my_url”, “token”: “my_token” }]

When I do this, I see an error: “Unknown configuration setting”, for “sonarlint.connectedMode.servers”

Additionally, after setting up, I’m supposed to type the command “SonarLint/UpdateServersAndBinding” into the command pallete, and yet when I try to enter that command, it says it’s unknown.

Can someone shed some light on this? Thanks!


(Inna Nill) #2

Does anyone have any thoughts about this? We are still struggling with this and are no closer to an answer. Is there a bug that I don’t know about that might help explain this?


(Julien Henry) #3

Hi @innanill. I just tried again, and it works fine for me.

"Unknown configuration setting”, for “sonarlint.connectedMode.servers”

Where do you see this error? In the SonarLint output panel? Or somewhere else in VSCode UI?

Is there any interesting message in the SonarLint output panel?


(Inna Nill) #4

The message appears in the Problems section at the bottom of the screen in VSCode.

settings.json
– Unknown configuration setting (3,5)

The “sonarlint.connectedMode.servers” is also underlined in green on the right hand side of my main screen where I’m editing the user settings, and when I hover over it, the same message appears.


(Julien Henry) #5

I’m suspecting a broken installation of the extension. Can you open ~/.vscode/extensions/ and check that there is only one SonarLint version (should be sonarsource.sonarlint-vscode-1.5.0). Then open sonarsource.sonarlint-vscode-1.5.0/package.json and check that it contains the settings definition:

"contributes": {
    "configuration": {
        "title": "SonarLint",
            "properties": {
                [...]
                "sonarlint.connectedMode.servers": {

In any case, you can try to delete the extension folder and install again.


(Inna Nill) #6

Ah! Good catch! Looks like I have SonarSource.sonarlint-vscode-1.2.0, as well as 1.5.0 in there. Can I just get rid of the 1.2.0 by deleting the folder, or should I remove it via VSCode somehow?

Thanks!


(Julien Henry) #7

I think deleting the folder and restarting vscode should be ok.


(Inna Nill) #8

I think that worked. Thank you!