Cannot import GitHub project (Already imported)

When trying to import the project che-che4z-lsp-for-cobol, SonarCloud claims that this project is already imported, but it is in fact not (or not visible).

We’ve tried to tweak the GitHub app configuration several times, enabling/disabling the mentioned project and also tried to remove the SonarCloud GitHub app completely from the org. It’s still not possible to import the project che-che4z-lsp-for-cobol. Other projects from the same org can be imported without issues (e.g. che-che4z-lsp-for-hlasm).

Please let us know how this can be fixed or if this needs SonarCloud staff assistance.

Hi @eclipsewebmaster ,
Thanks for reaching out. We’ll investigate this issue and we might reach out to you for further information if needed.

Hi Nawar,
Did you have a chance to look at this issue?

Hi @eclipsewebmaster
We could not find this project in your org list on the SC side. I’m trying to dig into this deeply with the team to understand the root cause. I’ll try to bring up some updates next week.


1 Like

Hi Nawar, gentle ping. Any update?

Hi @eclipsewebmaster ,

I sent you last week a private message with some additional information that I need, I’m still waiting for your reply!

Sorry about that. I’ve just just replied.

To follow up:

  • the project was indeed already imported, but with a different name that I would not have been able to identify without Nawar’s help.

It would be nice if the UI would show where a project is already imported to avoid such situations in the future.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.