C++ project "build-wrapper-dump.json" file was found empty

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
    SonarQube, SonarScanner 4.8 Linux
  • how is SonarQube deployed: zip, Docker, Helm
  • what are you trying to achieve
    Trying to get the scan to work locally before deploying it via GutHub Actions
  • what have you tried so far to achieve this
    I have tried building via make clean, but the “build-wrapper-dump.json” keeps being empty.
    build-wrapper-linux-x86-64 --out-dir bw-output make clean all -j 4 -C build

Therefore the scan fails with

java.lang.IllegalStemphasized textateException: The “build-wrapper-dump.json” file was found empty. Please make sure that:

  • you are using the latest version of the build-wrapper and the CFamily analyzer
  • your compiler is supported
  • you are wrapping your build correctly
  • you are wrapping a full/clean build

build-wrapper.log (202.8 KB)

Hello @jonashzf, and welcome to the community

I can see the calls to the compiler, but the compiler processes do not appear on the logs. This makes me think they are statically linked, and statically linked binaries are not supported. Can you double-check?

$ file -L /home/developer/src/LiRE_12_4_0/x86_64-linux-gnu/bin/x86_64-linux-gnu-c++