C# code stopped being detected on July1 using CI

I can’t get the CI upload of reporting to detect my C# code. This worked since last year, but it suddenly stopped working starting July 1.
It’s only detecting .css in the project.
If I turn on Automatic Analysis, then it detects the code.
I tried updating the GitHub action to JDK 17, but that didn’t help.
I am not sure how to troubleshoot this at this point. The github action didn’t change between June 30 and July 1.


Welcome to the community!

Which scanner are you using?


We’re using the dotnet v6 scanner tool.

      dotnet tool install --global dotnet-sonarscanner
      dotnet sonarscanner begin /d:sonar.verbose="true" /o:[org] /k:[key] /v:${{ inputs.artifact-version }}  /d:sonar.login=${{ secrets.sonar-cloud-token }} /d:sonar.host.url=https://sonarcloud.io /d:sonar.cs.vscoveragexml.reportsPaths=coverage.xml
      dotnet sonarscanner end /d:sonar.login=${{ secrets.sonar-cloud-token }}


Can you provide your full (debug) analysis log?

The analysis / scanner log is what’s output from the analysis command. Hopefully, the log you provide - redacted as necessary - will include that command as well.

This guide will help you find them.