BadRequestException: Rule with UUID AYRteBGA1BMwtCaoz61- not found when I upgrade to 9.7 from 8.9


I am testing the migration of our sonarqube enterprise 8.9.10 to version 9.7.1.
It’s a migration via docker: I deleted the existing 8 container, and I updated the image taking the 9-enterprise.
I also updated docker as I had the issue referenced here: [SONAR-15167] - Jira
Only when migrating the database, I have the following error message:
BadRequestException: Rule with UUID AYRteBGA1BMwtCaoz61- not found

I tried again by putting back a backup of the database before migration, and I deleted the plugin that I had added by hand (sonar-dependency-check-plugin-3.0.1.jar) same result.

OS: Centos 7
docker : 20.10.21
To image Sonarqube : 9-enterprise
From image sonarqube : 8-enterprise

Thank You


1 Like


I tried with the 9.5 enterprise version to see if that changed anything, but it’s the same error.
A priori it happens when loading the rules of the python plugin.
I forgot to indicate that I was using a postgresql 10 database.

Would you have an idea?

Hello @Ricetrac thanks a lot for taking the time to participate in the community.

We tried replicating your migration on docker with the same images and plugin, and everything succeeded.

The sonar-dependency-check-plugin is an unsupported plugin registering rules, but regarding the error message it could be related to elasticsearch.

If you are using our docker-compose example or persistent volume for /opt/sonarqube/data could you try run your backup again on sonarqube8 with the plugin removed, then exec inside the sonarqube container and remove /opt/sonarqube/data/es7 then running the application again ?

Waiting forward for you inputs,


Hi Jeremy,

I tried again but applying a VACUUM on my postgresql database before launching sonarqube, and that solved the problem.
Sorry, that was basically just that. I don’t understand how it changed anything, but it worked.
Thanks for the help anyway.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.