BadRequestException: Rule with UUID AX9QeQ0IaY1Ig7aAz3r- not found


Can some one help on this urgently. i am USING Sonar version

  • Version 9.3 (build 51899)- facing the above referenced issue.
  1. Background initialization error - after seeing DB errors and restarting Pods.
2022.10.21 21:28:20 ERROR web[][o.s.s.p.Platform] Background initialization failed. Stopping SonarQube
org.sonar.server.exceptions.BadRequestException: Rule with UUID AX9QeQ0IaY1Ig7aAz3r- not found
        at org.sonar.server.exceptions.BadRequestException.create(
        at org.sonar.server.exceptions.BadRequestException.create(
        at org.sonar.server.exceptions.BadRequestException.checkRequest(
        at org.sonar.server.qualityprofile.RuleActivationContext.doSwitch(
        at org.sonar.server.qualityprofile.RuleActivationContext.reset(
        at org.sonar.server.qualityprofile.RuleActivator.activate(
        at org.sonar.server.qualityprofile.BuiltInQProfileUpdateImpl.update(
        at org.sonar.server.qualityprofile.RegisterQualityProfiles.update(
        at org.sonar.server.qualityprofile.RegisterQualityProfiles.lambda$start$1(
        at org.sonar.server.qualityprofile.RegisterQualityProfiles.start(
        at org.sonar.core.platform.StartableCloseableSafeLifecyleStrategy.start(

We tried to restore the DBs from previous backups but the issue seems to be in the backup as well.

We also redeployed the app and we still get the same issue.

Any help will be greatly appreciated,



Are you using any 3rd-party plugins?


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.