Automatic analysis not available on private GitHub repository

We use with private repository. We have over a dozen of projects but most are analyzed through a CI pipeline.
Yesterday we have a new repo that was created but we have not added a CI pipeline with the Sonar Runner yet. In the past we were able to see the project show up in SonarCloud and let have it perform an automatic analysis so we could check for defects early on in the project.

All the code is Go, so there should be no issue to get it analyzed without a runner. We manually added the project on Sonar but we are not seeing the option for automatic analysis.

On the GitHub side the Sonar Application is configure to access all the repositories.

Hello @sodul ,

Could you clarify the following points:

  • How many repositories do you have in your organization?
  • What is the name of the repository that is not showing up (if you are not comfortable sharing it publicly then please send me a private message)?
  • Did you try using the search box when trying to add the repository?
  • Did you select the correct organization from the dropdown?


Hi @Martin_Bednorz,

  • we have less than 20 repositories at the moment.
  • we see this issue with multiple repositories, more details in PM.
  • yes, the newer repos are just not listed.
  • yes, we are on the correct org since we see other existing projects under the same org.

We solved the problem in a private thread. @sodul I marked the topic as solved, please comment if there are any other issues with this.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.