404 Error during Pull Request

Hi - We are getting the following error when trying to run a pull request:

ERROR: Could not find the pullrequest with key ‘5609’
ERROR: Error during SonarScanner execution
ERROR: Could not find the pullrequest with key ‘5609’
INFO: ------------------------------------------------------------------------
##[error]ERROR: Caused by: Error 404 on https://sonarcloud.io/api/alm_integration/show_pullrequest?project=[NAME]&pullrequestKey=5609 : {“errors”:[{“msg”:“Requested resource wasn’t found on Azure DevOps.”,“reason”:“AZURE_DEVOPS_UNABLE_TO_FETCH_REQUESTED_RESOURCE”}]}
ERROR:
ERROR: Caused by: Error 404 on https://sonarcloud.io/api/alm_integration/show_pullrequest?project=[NAME]&pullrequestKey=5609 : {“errors”:[{“msg”:“Requested resource wasn’t found on Azure DevOps.”,“reason”:“AZURE_DEVOPS_UNABLE_TO_FETCH_REQUESTED_RESOURCE”}]}
ERROR:
##[error]The SonarScanner did not complete successfully

  1. The PR with Key 5609 definitely exists and,
  2. We had this integration work successfully when the repo was connected to another SC account. We are attempting to move this project to our enterprise account.

Hi,
I work on the same team as @kyletk and originally reported the issue to him. Would add to this that the Azure DevOps pipeline runs fine when initiated outside the context of the pull request Build Validation policy, i.e., manually from within the pipeline itself.
Andrew

Hi @avanherick and @kyletk

We shall need the full log of the pipeline in that case, preferably in debug mode. Is that possible ? I can PM one of you if you want to share that privately.

Let me know.

Thanks

Hi @mickaelcaro,

I can provide the logs. PM would be great. What’s the best way to get in touch? I haven’t been able to figure out how to initiate a private communication channel with you on this platform. Is that something you can initialte?

Andrew

Hi @mickaelcaro,

Checking back in on this. What’s a good way to get in touch with you privately?

Anrew

Hi @avanherick

I sent you a message some days ago, check your inbox, you should have received it.

Mickaël

Hi @mickaelcaro ,

To which inbox did you send the message? I’ve checked my email address associated with the GitHub identity I used to establish my access here and only see forwards of public correspondence in this ticket. I’m not sure what other inbox to check.

Andrew

That’s directly in this forum. Click on your Profile picture on the top right corner, there should be a message tab.

Got it. Somehow I missed that. Thanks. Will respond in PM.

1 Like