Windows service update executable location

Hello,

I upgraded my SonarQube from 8.2 to 8.9lts and then finally to 9.3. Everything went fine but of course now the Windows service nolonger functions. I have to run SQ manually to get it up and running. I’ve figured out how to update the information in the already installed SonarQube windows service using the command:

sc config SonarQube binPath= “”$NEW_SONAR_HOME\bin\windows-x86-64\wrapper.exe" -s “$NEW_SONAR_HOME\conf\wrapper.conf”"

It seems to be updated in the service when I check it but when I run it I just get the " Error 1053: service did not respond in a timely fashion"

What’s the trick to get it working again?

Ken-

Hi Ken,

Welcome to the community!

Except for a missing backslash, I see very little difference between what you’ve done & what’s in the docs.

However, I wonder if that missing (from yours) backslash isn’t necessary to keep the 2nd " from immediately closing the first one…? (It has been a very long time since I worked in Windows.)

Also I notice that your (copy/pasted???) command has a mix of curly quotes and straight quotes. Since I’m barely Windows-literate these days, I have to ask whether in a command line / script context they’ll be treated identically by the OS…?

 
Ann

Ann,

Thanks a million for this! Total brain dead move there. It turned out to be both the curly quotes and a bad path to $NEW_SONAR_HOME :rofl:

Works like a champ now.

Appreciate the help.

Ken

1 Like