Why does the Enterprise Edition start without response?

Hello,

I know that the prerequisite for sonarqube is jdk11, but my environment can only use jdk1.8, so I tried to use zulu’s installation free java11, which can be started normally on the community version 9.5.
The effect is shown in the following figure.

All this seems normal, but when I tried Enterprise Version 9.6, there was no response when I ran StartSonar.bat, and the log report only one line record.

Please kindly tell me how to start Enterprise Edition normally?

Thank you for your patience.

Best Regards,

Kevin

Hey there.

Check the docs for 9.6.

Adjusting the Java Installation

By default, the scripts will use the Java executable available in the PATH. If there are multiple versions of Java installed on your server, you may need to explicitly define which version of Java is used.

It is possible to overwrite the default Java executable by setting the environmental variable SONAR_JAVA_PATH

Linux / MacOS

export SONAR_JAVA_PATH="path/to/java_home/bin/java"

Windows

setx SONAR_JAVA_PATH "C:\Program Files\java_home\bin\java.exe"

Hi,Colin,

Thank you for your reply. I still have some confusion.

I currently use Windows,
“C:\Program Files\java_home\bin\java.exe” ,
is this path a fixed value?
And my current environment is jdk1.8.Don’t I need to change the SONAR_JAVA_PATH path to the java11 path?

Best,
Kev

Hello Colin,
we added this SONAR_JAVA_PATH, but it doesn’t work.

In addition, there is no relevant error report in the log folder, only there is a line


2022-11-22 15:42:44,143 DEBUG  - Starting WinSW in console mode

in the SonarServiceWrapper.wrapper.

Where else can I continue to work until my SQ can start normally?

Best,
Kevin