When will SonarFindBugs 3.8 be available from GUI

findbugs

(Mikael Petterson) #1

Must-share information (formatted with Markdown):
Findbugs 3.7.0
SonarJava / 5.7.0.15470
SonarQube Server / 6.7.5.38563

  • We need to run analysis on java 10 code. Therefore we need the following fix in:

Analysis fails on Java 10 #184

When will you make it available for download from Marketplace?

br,

//mike


(G Ann Campbell) #2

Hi,

I’m going to take this as the friendly joke it was intended to be. After all, the release of the FindBugs 3.8 plugin was only announced 12 hours ago. I was putting on my jammies at the time, and my European colleagues were sound asleep (I hope).

Ann


(Mikael Petterson) #3

:blush: I did not know you have to sleep also :smiley:
I sleep from time to time too…

I look forward to new release. Thanks for great support!


(Mikael Petterson) #4

Hi,

I found the following message in sonar admin gui:

But sonar-findbugs says:

3.8.0
Support SonarQube 7.3+, Update to spotbugs 3.1.6, fb-contrib 7.4.3.sb, findsecbugs-plugin 1.8.0.

On the https://github.com/spotbugs/sonar-findbugs you can read this:

Findbugs Plugin version Embedded SpotBugs/Findbugs version Embedded Findsecbugs version Embedded FB-Contrib version Minimal Java version Minimum SonarQube version Minimum sonar-java version
2.4 2.0.3 N/A 5.2.1 1.6 4.2 2.4
3.0 3.0.0 N/A 6.0.0 1.7 4.2 2.4
3.2 3.0.1 1.3.0 6.0.0 1.7 4.5.2 2.7
3.3 3.0.1 1.4.2 6.2.3 1.7 4.5.2 2.7
3.4 3.0.1 1.4.6 6.6.1 1.8 5.6 3.13.1
3.5 3.1.0 RC1 (SpotBugs) 1.6.0 7.0.0 1.8 5.6.6 4.0
3.6 3.1.0 RC4 (SpotBugs) 1.6.0 7.0.0 1.8 5.6.7 4.15.0.12310
3.7 3.1.2 (SpotBugs) 1.7.1 7.2.1sb 1.8 6.7.1 5.1.0.13090
3.8 3.1.6 (SpotBugs) 1.8.0 7.4.3sb 1.8 6.7.1 5.1.0.13090

So why is it stated in admin gui that you have to have sonarqube 7.3?
This means I cannot install it on our SonarQube 6.7.5… Why?

br,

//mike


(G Ann Campbell) #5

Hi,

Just to wrap this thread up, as you discovered the maintainer published the plugin with a compatibility statement of “>= 7.3”.

Ann


(Vinod Anandan) #6

Apologies @eraonel and @ganncamp . I made a mistake the with the version. I have requested in the original post to update it to appropriate compatibility.

Thank you very much for noticing the mistake.

Regards,

Vinod