Webstorm - SonarLint connection to SonarCloud issue

Please provide

  • Operating system: MacOS
  • SonarLint plugin version:
  • Programming language you’re coding in: Angular
  • Is connected mode used:
    • Connected to SonarCloud or SonarQube (and which version): Connection can’t be established.

And a thorough description of the problem / question:
Trying to add a SonarCloud connection goes as far as token. After inputing the generated token from SonarCloud this error pops up instead of the organisation list.

Failed to query organizations. Please check the configuration and try again. Error: Cannot invoke “java.util.List.size()” because the return value of “org.sonarlint.intellij.tasks.GetOrganizationsTask.organizations()” is null

The connection test from proxy settings works just fine so not sure what’s causing this.


Same issue here.

=== About ===
Build version: IntelliJ IDEA 2023.2 Build: #IU-232.8660.185 July 26, 2023
Theme: Dark
JRE: 17.0.7+7-b1000.6, JetBrains s.r.o.
JVM: 17.0.7+7-b1000.6, OpenJDK 64-Bit Server VM, JetBrains s.r.o.
Operating System: Mac OS X 13.3.1 (aarch64)
idea.config.path=/Users/andreasevers/Library/Application Support/JetBrains/IntelliJIdea2023.2
idea.plugins.path=/Users/andreasevers/Library/Application Support/JetBrains/Toolbox/apps/IDEA-U/ch-0/232.8660.185/IntelliJ IDEA 2023.2 EAP.app.plugins

=== Plugins ===
Custom plugins: [GitHub Copilot (, Spring Javaformat (0.0.38), Apache Avro IDL Schema Support (213.5.2), Terraform and HCL (232.8660.88), AI Assistant (232.9353), CSV Editor (3.2.1-232), SonarLint (, CamelCase (3.0.12), Co-Author (2.3), CheckStyle-IDEA (5.81.0)]
Disabled plugins:[GlassFish (232.8660.185), WildFly (232.8660.185), Tomcat and TomEE (232.8660.185), Jakarta EE: Application Servers (232.8660.185)]

Hi, thank you for your reports.

I identified the issue and created this ticket as a result. The fix will be probably part of a patch once all the issues of the 8.5 have been resolved.

In the meantime, and if that’s a blocker, we invite you to downgrade to the previous 8.4 version by following the steps to directly install the plugin from disk while we work on resolving the issues.

We released a new patch, version 8.5.1. Could you please update your SonarLint and see if the issue is resolved?

Just tried connecting with version 8.5.1 and it worked! Thanks for the speedy fix.

1 Like

Works for me too!

1 Like