`WaitforQualityGate` problem

Hi ,

I am also facing the same issue. My sonarqube version is 6.7. The below is my pipeline snippet:

node(“mesos”) {
stage(‘build && SonarQube analysis’) {
def scannerHome = tool name: ‘Sonar-Scanner’, type: ‘hudson.plugins.sonar.SonarRunnerInstallation’
withSonarQubeEnv(‘my_sonar_server_name’) {
sh “${scannerHome}/bin/sonar-scanner”
timeout(time: 1, unit: ‘HOURS’) {
// Parameter indicates whether to set pipeline to UNSTABLE if Quality Gate fails
// true = set pipeline to UNSTABLE, false = don’t
waitForQualityGate abortPipeline: true,credentialsId:‘my_user_token’

Does anyone know how i can resolve it?


Hi Sushmita,

Welcome to the community!

I’ve moved your post out of the old thread you had resurrected to a new topic. Please flesh this one out with the details of what is/isn’t happening.