Upgrade to latest LTS reports unsupported JAVA version

Hi there,

I wanted to upgrade this morning from 9.6.1 to 9.9.0 on our server. The server is a Windows Server 2019 with Java 11 (IBM Semeru and MSSQL database.

Now when I run startSonar.bat I get the following error:

Error: LinkageError occurred while loading main class org.sonar.application.App
        java.lang.UnsupportedClassVersionError: JVMCFRE199E bad major version 61.0 of class=org/sonar/application/App, the maximum supported major version is 55.0; offset=6

Here some more details and test I run:

As far as I understand the output it reports an mismatch of JAVA version which shall be 17 (major version 61.0) but this machine only has JAVA11 installed as you can see in the screenshot.

Any ideas, how I can get this LTS version to work?

Thank you in advance for your support.

In case you need further details, please let me know.


Welcome :slight_smile:

Sonarqube 9.9.0 LTS needs to run with Java 17 now, see


Gilbert, thank you for the quick reply and the link. I have overseen this in my preparations.

I would then suggest to reformulate the error message a bit because I understood it detected JAVA17 (major version 61.0) and only supports until JAVA11 (major version 55.0). But it is the other way around. So, the wording should better be something like this:

JVMCFRE199E bad major version 55.0 of class=org/sonar/application/App, the minimum supported major version is 61.0; offset=-6

Doesn’t that make more sense?

every Java Developer or admin of a Java application is used to this error and should know how to
interpret / handle it.
Your proposal

would be wrong, as it’s major version is 61.0 not 55.0

Yeah, indeed I’m a C++ developer and build pipeline administrator. My exposure to JAVA was very limited so far.

I think we are talking about the same thing but from different ends. My expectation was, the application (here SonarQube) states “I need JAVA17 to run, but only found JAVA11”. But as I understand the message it is reported the other way around from JAVA and I got confused by “the maximum supported major version is 55.0” (55 is JAVA11 is I’m not mistaken).

Anyway, the installation of JAVA17 solved the issue.
Thank you.

1 Like