Unable to restart sonarqube 7.9.3 community edition after marketplace plugin update

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension) 7.9.3 community edition,
  • what are you trying to achieve
  • what have you tried so far to achieve this
    I updated the below listed plugins available on the marketplace but post the update sonarqube did not start. Can you please help.
    Plugin list:

Error message -
2020.05.26 17:21:45 INFO web[o.s.s.s.RegisterMetrics] Register metrics
2020.05.26 17:21:45 INFO web[o.s.s.r.RegisterRules] Register rules
2020.05.26 17:21:46 INFO web[c.h.s.i.s.SonargraphRulesProvider] Sonargraph Integration: Loaded standard rules file ‘/com/hello2morrow/sonargraph/integration/sonarqube/SonargraphRules.properties’
2020.05.26 17:21:46 INFO web[c.h.s.i.s.SonargraphRules] Sonargraph Integration: Created 19 predefined rule(s)
2020.05.26 17:21:46 ERROR web[o.s.s.p.Platform] Background initialization failed. Stopping SonarQube
java.lang.NoSuchMethodError: ‘void com.google.common.base.Preconditions.checkArgument(boolean, java.lang.String, java.lang.Object, java.lang.Object)’
" at com.google.common.io.Resources.getResource(Resources.java:207)"
" at com.cognifide.aemrules.extensions.RulesLoader.loadResource(RulesLoader.java:126)"
" at com.cognifide.aemrules.extensions.RulesLoader.loadDescription(RulesLoader.java:119)"
" at com.cognifide.aemrules.extensions.RulesLoader.createRule(RulesLoader.java:87)"
" at com.cognifide.aemrules.extensions.RulesLoader.lambda$loadRule$0(RulesLoader.java:80)"
" at java.base/java.util.Optional.map(Unknown Source)"

The stacktrace suggests an issue coming from the Cognifide/AEM-Rules-for-SonarQube. Look like there’s a v1.1 release meant to be compatible with newer versions of our Java analyzer (which I can’t tell if it’s installed on your instance or not. If not, it probably needs to be).

@Colin_SonarSource, Thanks for the reply. I had updated all the plugins listed in the screenshot and the AEM-Rules-for-Sonarqube was also updated to V1.1 and that’s when i ran into the issue when i restarted the server. Could you please let me know if it has any dependency on any Quality profile or rules etc. Anything specific that i need to look into ?
Also could you please let me know if there is recommended approach to update the plugins e.g. updating the plugin one by one and restart the server everytime i update a single plugin or can i update all the plugins in one go and then restart the server.

Thanks in advance.

Hi @Colin_SonarSource, Could you please let me know if you are referring to this java analyser -
Java Code Quality and Security Languages

Code Analyzer for Java * 6.3 (build 21585) installed

Most of the time you should be fine to go all at once. :slight_smile: But we recommend testing on a non-production instance.

Probably a question that’s best suited for the plugin maintainers. I linked them earlier!

Yes. It appears to be a dependency of the AEM-Rules plugin, so it should probably be installed.

If you still face issues, your best point of contact is the plugin maintainer for AEM-Rules! For example, raising an issue on their Github repository.

Hello Colin_SonarSource

We are using Sonarqube 8.0 enterprise edition and our sonar service is failing to start after installing AEM rule 1.1 plugin.
Please confirm whether plugin 1.1 is compatible with Sonarqube 8.0?

Thanks