Unable to find SonarQube project settings...in Jenkins

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
  • what are you trying to achieve
  • what have you tried so far to achieve this

Hi guys;

As title says, unable to find SonarQube project settings. I have a GitHub repository on my computer:


Contained within that, there is the SonarQube settings file which contents are as follows:




The output log file generated by Jenkins whenever I attempt to use the “build now” feature of Jenkins is as follows:


Using sonar-scanner-
Have tried different variants, / instead of , etc.
Have authenticated SonarQube with secret token.

Unsure as to how to proceed.


Welcome to the community!

It’s not clear to me from this

how you’ve configured the analysis, how you’re passing in those analysis parameters, and exactly what “Documents/GitHub/coursework_1/sonar-server.properties” is supposed to be. Could you share screenshots of the analysis portion of your job configuration?