Unable to create a configuration for Gitlab on sonarqube

Hi everyone,

I’ve installed a new instance of Sonarqube version: 8.7.0.41497 on my server. When I try to create a configuration for my gitlab instance, I’m getting this error Unknown url : /api/alm settings/count_bindin… When I try to deleted that configuration, the same error.

@Malena_Ebert , any help will be welcomed.

Hi @Harold_Ibouanga ,

while i am not Malena i will try my best to help you :wink:

can you elaborate your current setup a little? i assume that we are not talking about gitlab.com but a self hosted gitlab installation; is the instance configured with LTS and is the certificate a valid one or self signed?

Also please note that we just released sonarqube 8.8 with a bunch of improvements and bugfixes, so maybe a update would already resolve your issue

Hi @Tobias_Trabelsi,

I’m using self hosted Gitlab EE 13.10 on top of Debian 10.8 with a valid certificat. But for The sonarqube instance on Debian 10.8, there is no valid certificat.

I’ll try the update and see how it solve my issue.

Thanks for your support.

Hi @Tobias_Trabelsi ,

After updating my sonar instant to 8.8, I was able to create a gitlab configuration. But I’m still not able to remove a configuration. Still getting {“errors”:[{“msg”:“Unknown url : /api/alm_settings/count_binding”}]} when trying to delete a configuration.

Thanks for your support.

Hi, which SonarQube edition are you using? (Community, Developer, Enterprise, DCE)

Hi, I’m using Community Edition Version 8.8 (build 42792).

Thanks for the detail. I’m able to reproduce this. Bug ticket is here, we will definitely fix this.

In the meantime, you can use the API directly to delete the configuration, as a workaround (see here for API authentication):

curl --request POST -u THIS_IS_MY_TOKEN: https://sonarqube.com/api/alm_settings/delete?key=xyz

The key is what’s defined as Configuration name for your Gitlab configuration.

1 Like

I was able to delete the configuration throught the API.
Thank you.

1 Like