The resource for '' is not found, drilling down to the details of this test won't

I am getting these errors from the scans.

The resource for ‘’ is not found, drilling down to the details of this test won’t be possible

What does this error mean and is there a general solution to resolve it?


Hey there.

What language(s) are you analyzing? As mentioned in the template post, what version of SonarQube are you using?

Hi Colin,

Thanks for responding.

It’s scanning python 3.8 code. I see SonarScanner in the log. Is that sufficient version info?

Let me know if you need more info.


Hey there.

Your SonarQube version can be found in the footer of your instance.

My mistake.

We are using the SonarCloud. I don’t see a way to find the version of the cloud version.

Okay. You fooled me putting this into the SonarQube category. :slight_smile:

Can you turn on DEBUG logging (sonar-scaner -X). It shoudl give some more information about looking up test files related to a test reported in the test execution report.

Thanks. I’ve added the debug flag and figured what is wrong.

How do I exclude folders from being scanned?

I tried
sonar-scanner -Dsonar.coverage.exclusions=xxx/**
sonar-scanner -Dsonar.exclusions=xxx/**

I see the following DEBUG info messages:
INFO: Excluded sources: xxx/**
INFO: Excluded sources for coverage: xxx/**

However, it still scans the folders

I’ve also found that I can set the exclusion in SonarCloud → (project name) → Administration → General Settings → Analysis Scope

I’ve tried excluding the directories there. The debug INFO messages will include the directories I’ve excluded, but the scan will give the same WARNING messages (The resource for “” is not found…)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.