The mobile application pipelines(azure devops) are failing at sonarqube analyze step

Error message:

##[error]19:57:13.928 The SonarScanner for MSBuild integration failed: SonarQube was unable to collect the required information about your projects.
Possible causes:

  1. The project has not been built - the project must be built in between the begin and end steps
  2. An unsupported version of MSBuild has been used to build the project. Currently MSBuild 14.0.25420.1 and higher are supported.
  3. The begin, build and end steps have not all been launched from the same folder
  4. None of the analyzed projects have a valid ProjectGuid and you have not used a solution (.sln)

Its running on Microsoft agents.
We tried on macOs-latest,macOS-11 and macOS-12
SQ version : 9.9
Agent machine name: ‘Mac-1706899552164’

Current agent version: ‘3.232.3’

Operating System

Runner Image

Runner Image Provisioner

Current image version: ‘20240105.1’
Downloading task: PowerShell (2.232.1)
Downloading task: NuGetToolInstaller (1.231.0)
Downloading task: NuGetCommand (2.231.0)
Downloading task: SonarQubePrepare (5.19.0)
Downloading task: XamariniOS (2.231.0)
Downloading task: SonarQubeAnalyze (5.19.0)
Downloading task: SonarQubePublish (4.9.4)
Downloading task: AndroidSigning (3.231.1)
Downloading task: sonar-buildbreaker (8.1.2
Downloading task: PublishPipelineMetadata (0.234.0)

NuGet Version:
MSBuild auto-detection: using msbuild version ‘15.0’

SonarScanner for MSBuild 5.13

Using the .NET Core version of the Scanner for MSBuild

This pipeline was working fine until last month .what might be the possible reasons?

1 Like

Hey there.

I would bet it has something to do with this thread.

We’re working on a fix. Can you try forcing a lower version of .NET to be used, like this user did, as a workaround?

Thanks Colin and Denisyakimov07

This Solution worked for us.

  • task: UseDotNet@2
    version: 7.0.404
    displayName: UseDotNet 7.0.404