The Last Analysis has failed: AW8SXCf_yk8RU8t9umNy

I’m trying to run the analysis using the community edition SonarQube 8.0. I’m trying to analyze an open source java project that was created using ant. so I have already downloaded the ant plugin and all the necessary plugins. I have also edited the build.xml file. however after attempting to run the analysis for couple of time I getting that ANALYSIS SUCCESSFUL, you can browse http://localhost:9000/dashboard?id=magarena.

my scanner context is as following
SonarQube plugins:

  • CVS 1.1.1 (scmcvs)
  • 3D Code Metrics 3.7 (citymodel)
  • SonarScala (sonarscala)
  • SonarC# (csharp)
  • SonarJava (java)
  • Sonargraph Integration 4.0.0 (sonargraphintegration)
  • SonarHTML (web)
  • SonarFlex (flex)
  • SonarXML (xml)
  • SonarTS (typescript)
  • Checkstyle 4.26 (checkstyle)
  • Java I18n Rules 1.0-SNAPSHOT (javai18n)
  • SonarVB (vbnet)
  • SonarPython (python)
  • Code Smells 4.0.0 (smells)
  • JaCoCo (jacoco)
  • SonarGo (go)
  • SonarKotlin (kotlin)
  • jDepend 1.1.1 (jdepend)
  • Swift (Backelite) 0.4.5 (backelitesonarswiftplugin)
  • SonarJS (javascript)
  • SonarRuby (ruby)
  • Groovy 1.6 (groovy)
  • Git (scmgit)
  • SonarPHP (php)

Global server settings:

  • sonar.core.startTime=2019-12-16T23:32:43-0500
  • sonar.dbcleaner.hoursBeforeKeepingOnlyOneSnapshotByDay=36
  • sonar.dbcleaner.weeksBeforeKeepingOnlyOneSnapshotByWeek=6
  • sonar.groovy.ignoreHeaderComments=false

Project server settings:

  • sonar.scm.disabled=true
    Project scanner properties:
  • /magarena/magarena-1.95/lib/*.jar
  • sonar.login=******
  • sonar.projectBaseDir=/Users/mouzaalblooshi/Desktop/analyzer/projects /magarena/magarena-1.95
  • sonar.projectKey=magarena
  • sonar.projectName=magarena
  • sonar.projectVersion=1.0
  • sonar.scanner.appVersion=
  • sonar.sourceEncoding=UTF-8
  • sonar.sources=.
  • /magarena/magarena-1.95/.scannerwork

But when I checked the server it says that the last analysis was failed. I have tried running the analysis couple of time with even different Projects I was getting the same error that the last analysis was failed. I even tried to run the analysis without ant just with the scanner command. I have also tied to look in the background tasks / the gear icon but couldn’t see an “Error logs”. I need to complete this analysis ASAP. I will really appreciate your help.


Hi mou,

Welcome to the community!

Unfortunately we’re not going to be able to help you diagnose this without some kind of error logs. IIRC CE logs might get purged after a while. Try checking for errors immediately after analysis.


Hello Ann

Thanks a lot for your reply. I have already changed the version of sonarqube to 8.1.
However, I have another question which version of sonarqube is more stable since I need to run analysis for 1000 open source project for my research so can you please suggest which one will be more convenient to be used. I will appreciate your help


Hi Mouza,

All versions of SonarQube are production-ready, and can handle that load. However bug fixes are only back-ported to the LTS, which is currently 7.9.2. If your research will span several months, you might want the LTS. If not, then I’d go for the latest/greatest.


Dear Ann,
I know that all version of SonarQube are production-ready however I don’t know what is wrong with the versions that I download. First I downloaded SonarQube 8.0 and I run the analysis for four projects then when I tried to run the fifth one it says The last analysis has failed, I tried to restart the server couple of time done everything but still I couldn’t solve the problem then I decided to reinstall SonarQube with the latest version 8.1 and the same thing happened. I tried to analyze a project couple of time but it says The last analysis has failed, even though the EXECUTION was successful. please help with this. I can’t repeat the analysis every time. I even read other post in the form regarding this situation but I couldn’t see the error log in the gear icon of the background tasks, I only see the warnings and the scanner context. For instance today when I tried to analyze the project (AW-MxQ0kINSVBc27_0ZP) it gave me the same message.


Hi mouza,

Take a look at the docs on the topic and come back to us if you don’t understand the errors you find in the logs.


Thanks a lot Ann I really appreciate you help.