The last analysis has failed. Analysis ID: "AXGZHtNLSCCZ_FBK99dT"

As per advised in sonarcloud, please check the error for analysis ID: “AXGZHtNLSCCZ_FBK99dT”

1 Like

Welcome to the community!

Can you please tell on which day the analysis was running? (Even a rough date range is enough, but I need it to locate the relevant logs.)

Today was the last analysis run 8th of Jul 2020

Never mind, I found this failure in April this year. Does that sound about right?

We don’t keep logs long enough to be able to investigate this. It will be best to trigger a new analysis. Please let me know if that fails again, and the new analysis ID, and then we can investigate.

I used sonarcloud ms build script to build the app and analyze code coverage…etc, is that going to trigger the analysis on

The analysis ID “AXGZHtNLSCCZ_FBK99dT” is the last analysis of the master branch of the project, and it was in April. So this is a very old analysis.

If that is an analysis of the master branch, it doesn’t seem to be reaching If it is the analysis of another branch, or of a pull request, then I cannot tell yet, from the given information. (I would need to know the branch name or the pull request key.)

It sounds like it would, but the answer depends on your configuration, and the command executed to run the analysis. If you are expecting to see the analysis of your master branch on SonarCloud, then please share more details about your setup.

Yeah, I ran the script for another branch and it’s Release-202006-MFR-663

Regarding sonar ms build script, please check the following:

"C:\Program Files (x86)\sonar-scanner\SonarScanner.MSBuild" begin /k:"{project key}" /o:"{organization key}" /"Release-202006-MFR-663" /d:sonar.exclusions=**\*.html /d:sonar.cs.opencover.reportsPath=VisualStudio.coveragexml /d:sonar.cs.xunit.reportsPaths=XUnitResults.xml

"C:\Program Files (x86)\MSBuild\14.0\Bin\MSBuild.exe" "{visual studio solution location}" -property:Configuration=Release

"packages\Microsoft.TestPlatform.16.6.1\tools\net451\Team Tools\Dynamic Code Coverage Tools\CodeCoverage.exe" collect /output:VisualStudio.coverage /verbose:console "packages\xunit.runner.console.2.4.1\tools\net452\xunit.console.exe" "{unit tests dll location}" -xml XUnitResults.xml

"packages\Microsoft.TestPlatform.16.6.1\tools\net451\Team Tools\Dynamic Code Coverage Tools\CodeCoverage.exe" analyze /output:VisualStudio.coveragexml VisualStudio.coverage

"C:\Program Files (x86)\sonar-scanner\SonarScanner.MSBuild" end

I see all successful analyses of this branch.

What is the problem? If you would like to make the “The last analysis has failed…” message go away on the master branch, you need to run an analysis of the master branch.

Ok, I ran the script again for master branch and the error message is changed, please advise.

I ran the script again for master branch, Can you please check my latest reply!

When you get a red banner as in your screenshot, you can find the cause of the failure on the Background Tasks page. (The user in the screenshot doesn’t have access to that page, would have to ask an admin to do that.)

I can see successful analyses on July 15th, 2 days after your last post. It would seem you were able to resolve the issue on your own.

Please confirm!