The 'component' parameter is missing

Sonar quality gate in jenkins is throwing below error. It was running properly till last month now its throwing below error. Please check and help

org.quality.gates.jenkins.plugin.QGException: Expected status 200, got: 400. Response: {“errors”:[{“msg”:“The ‘component’ parameter is missing”}]}
at org.quality.gates.sonar.api.SonarHttpRequester.executeGetRequest(
at org.quality.gates.sonar.api.SonarHttpRequester.getComponentId(
at org.quality.gates.sonar.api60.SonarHttpRequester60.getSonarApiTaskInfoParameter(
at org.quality.gates.sonar.api.SonarHttpRequester.getAPITaskInfo(
at org.quality.gates.sonar.api.QualityGatesProvider.getAPIResultsForQualityGates(
at org.quality.gates.jenkins.plugin.BuildDecision.getStatus(
at org.quality.gates.jenkins.plugin.QGPublisher.perform(
at hudson.tasks.BuildStepMonitor$1.perform(
at hudson.model.AbstractBuild$AbstractBuildExecution.perform(
at hudson.model.AbstractBuild$AbstractBuildExecution.performAllBuildSteps(
at hudson.maven.MavenModuleSetBuild$MavenModuleSetBuildExecution.post2(
at hudson.model.AbstractBuild$
at hudson.model.Run.execute(
at hudson.model.ResourceController.execute(
Build step ‘Quality Gates Sonarqube Plugin’ marked build as failur


Which plugin are you using ? Is that a custom one ?


using for analysis and sonar quality get in jenkins.

Quality Gates Plugin 2.5
Sonar Quality Gates Plugin 1.3.1
Jenkins 2.164.1

Having the same issue, has anyone found a solution?


Some deprecated parameters have been remove recently, and the route called after analyzing the stack trace is one of.

As it is a 3rd party plugin, i suggest you to contact the developer directly, the repo seems here :

To request changes with newest implementation.



1 Like

Hi @amit & @Jonathan_Camargo,

Wr are landing with the same error. Did you guys figure out a solution for this?

Hi @amit & @Jonathan_Camargo @Vishal3

I upgraded sonar verion to 8.9.6 ( previous version 7.5 ), i am also facing same issue, Please share the solution if anyone have

Thanks in advance

I am also experiencing the same error with a recent upgrade via the API.