The build-wrapper-dump.json is empty on sonarqube 8.5 -Devloper Edition

When compiling using build-wrapper-linux-x86-64 to be able to analyze c/c++ code I get an empty build-wrapper-dump.json. This only happens on amazonlinux, running the same command in ubuntu works as expected.

This is the version of build-wrapper that I’m using:
build-wrapper, version 6.13 (linux-x86)

What I get in build-wrapper-dump.json is:
[builds@dma-dev-build build_output]$ cat build-wrapper-dump.json

© SonarSource SA, 2014-2020,

All SONARSOURCE programs and content are copyright protected.

SONARSOURCE and SONARQUBE are trademarks of SonarSource SA. All rights are expressly reserved.

This file is designed exclusively for use with the SONARSOURCE C / C++ / Objective-C Plugin.

It may not be used in connection with any other software.

Any other use is prohibited by law and may be grounds for immediate termination of your License.


The file:

Encoding of the source files


attached the build-wrapper.logs filebuild-wrapper.log (258.5 KB)

Hi @kishore535,

I don’t see any compiler invocation in the log file. I can see you are running make all, shouldn’t you run make clean all? What compiler are you using?

thanks @mpaladin , It worked. I added make clean all and it worked. Thanks a lot

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.