[squid:S00105] Disable linting rule in SonarLint in Intellij is not working. Cannot hide banner

  • SonarLint IntelliJ linked to SonarQube
  • Yellow banner being displayed for squid S00105 Replace all tab characters in this file by sequences of white-spaces. Clicking disable rule does not seem to work. IntelliJ 2019.1 Ultimate.
  • No workaround seems to be possible.

Maybe this is because of the SonarQube integration, but it would be really nice to remove this banner on all files using tabs. I can’t remove the actual rule due to this being shared amongst other projects. Converting this entire project to spaces is possible, but I want to know why the disable option isn’t working.

Hello, sorry for the late answer.

In connected mode, settings from the SonarQube server will override any local analysis properties, including rule activation. Actually, you should not even see the “Disable SonarLint rule” action :sweat_smile: much in the same way that you won’t see it on issues inside source code (and it seems that we hit a bug in the IntelliJ platform here).

Now, if some files in your project legitimately contain tabs, you can either use a custom quality profile for your project, with rule S00105 disabled, or configure exclusions for these files.