Sonarscanner Timeout after 120s

This is image of issue.
I got issue three days ago.
I config sonar scanner in Jenkins and scan source code C#.
Sonarqube version 7.9.5
Dotnet core version 6. and 3.
Dotnet sdk version 6. and 3.
dotnet sonar scanner version 4.8.0
After I run sonar scan about 120s and it inform time out.
I configed bypass all ip and port.
And this is my config

I don’t know why. Please support me!!

Thank so much!!


Welcome to the community!

Your version is past EOL. You should upgrade to either the latest version or the current LTS at your earliest convenience. Your upgrade path is:

7.9.5 → 8.9.9 → 9.6 (last step optional)

You may find the Upgrade Guide and the LTS-to-LTS Upgrade Notes helpful. If you have questions about upgrading, feel free to open a new thread for that here.

If your error persists after upgrade, please come back to us.


I try this way.
I used .net core 2.1 and sonar .net core 2.1.
Now I can scan at local via using script. It worked and pushed report to sonar server.
This is script.

Then I move it on Jenkins pipeline, run failed and show logs:

It always point at sonarscanner for MSbuild 4.6.2 whether I point at folder contain sonarscaner-2.0 in Jenkins pipeline.

Please support me!
Thank you!


So much has changed since 7.9.5, there’s no way we can effectively support you. Please upgrade your system & come back to us if you still have problems.