Sonarscanner fails with HTTPS added to Sonarqube

Using developer edition SonarQube 9.5 (build56709) and Sonarscanner for msbuild 5.7.0. I have installed a wildcard certificate which belongs to our company with root CA being certum. I have installed the certificates on the %JAVA_HOME%/lib/security/cacerts files successfully using following command:

keytool -import -v -trustcacerts -alias Sonarqube -file -keystore cacerts

I tried the sslpoke SSLPoke from this site and it works fine
with successfully connected message.

I tried adding SONAR_SCANNER_OPTS to the prestart of scan and sonarscanner still fails to authenticate.

set"C:\Program Files\Eclipse Adoptium\jdk-\lib\security\cacerts""changeit"

Additional Info: Sonarqube is hosted on a VM and HTTPS is being done by IIS reverse proxy on the same VM. The https url works fine while trying to use from browsers. The scanner is being run on the same VM as well.

Hey there.

It’s not clear from the screenshot (and please, share text-based logs instead of screenshots) what the actual error you’re receiving in the end is. So far, it looks like you just receive some DEBUG/Warning messages.

Sonarprep.txt (6.1 KB)
scanner.txt (35.4 KB)

Please find the attached text log.

It looks like you might be only piping stdout to the logs instead of the full output (including stderr)

Sorry about that. Please find the proper logs below:
Sonarprep.txt (6.1 KB)
scanner.txt (66.1 KB)

When I try and visit (and go past the certificate error) I get a 404 error. Are you sure you have the URL right?

Hi, sorry the URL wont work from outside company network as its hosted inside the network, same as Sonarqube VM.

This is the output on chrome when I visit the URL: