SonarQube - setting up and using different quality profiles (version 6.7)

I am currently using SonarQube (version 6.7.6). I have admin access in SonarQube.
On the project dashboard, I am showing I am using “Swift + Sonar way” - a default quality profile. I would like to run an analysis with “Objective-C + Sonar way”. Realizing this is a default for another language, I tried to copy the Objective C default profile and named it.
Within the project I select Administration -> Quality Profile and selected the “copied profile”.
Another analysis ran, only the dashboard still shows the “Swift…” in the right portion of the screen.
How would we show and run multiple languages for an analysis?

Welcome :slight_smile:

you should update to current LTS which is 7.9.2 asap.
as your version is EOL already.
Every scanner that is installed ships with one or more quality profiles named ‘Sonar way’ or
‘Sonar recommended’, one of them is set as default.
Those quality profiles are not editable / immutable, so you have to create a copy as recommended
starting point for your custom quality profiles.
A scanner starts automatically to analyse if the sources matches its configuration -
see Administration > General Settings > $language
means the configured file extensions - and if they are included for the analysis, see

i.e. a java project including xml files will be analysed with the default quality profiles for
java and xml, if not set otherwise (every project may have non default quality profiles for
every scanner).
If you have swift and objective c code within your project both scanners should work
automatically - if installed for your Sonarqube instance.
When the dashboard shows only swift, that means there was no objective c code included
in your analysis.
Check your settings for objective c scanner and the in/exclusion settings of your analysis.


1 Like

Thank you. It ended up being this project had a setting of sonar.language = swift.
I’m not sure if this is still used.

sonar.language was removed with Sonarqube 7.7,
You must not use the sonar.language setting if you have a multi-language project with Sonarqube < 7.7
Did you try without the sonar.language setting ?