Sonarqube PID file is not existing

Hi guys,

  • sonarqube edition - Version 9.3.0.51899 community version on rhel 8.6

  • i have a problem with sonarqube status check. It seems that after unclean shutdown, sonarqube is starting, but if i run “sonar.sh status” the status is “SonarQube is not running.” If i check proces or logs everything seems good and sonarqube really work (is accesible from web console and we can use it). Probably the reason is that PID file is not existing.
    I also found that after start (“sonar.sh start”), a pid file is created in $SONARQUBE_HOME/. directory, but soon after this pid file is deleted. I also tried to comment out the commands to delete the PID file in the startup script, but it doesn’t help. I also restarted the whole server, but that doesn’t help either.
    If i check process with “ps”, other PID number (like the one that was in the deleted PID file) is corelated with sonarqube process.

Do you have any idea how to resolve this?

BR, Robi

Hi guys,
Solved. The problem was, that sonarqube was started like a service and when i tried to start “manually” with sonar.sh command, one instance was alive. When i stopped a service everything worked as i expected.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.