SonarQube local doesn't refresh the page


I have trying to run SQ Community locally in port 9000. I’m using docker and everything is running fine since I can login into localhost:9000 successfully.

So, I created a new project to analyze a code in my PC (which is also git monitored).

I executed dotnet sonarscanner begin, dotnet build and dotnet sonarscanner end, just copied and pasted it from the tutorial directly to cmd and everything ran just fine as you can see here:

However, the toturial page in localhost:9000 says that: Is my analysis done? If your analysis is successful, this page will automatically refresh in a few moments.

But this never happens. The page never refreshes. Am I missing something?

Many thanks!

hi andre,

i would like to enhance your question by asking a clarifying question:

are you asking

  • because the localhost:9000 page is not reloading by itself OR
  • because you cannot find a result for your analysis at localhost:9000 at all (even after manually reloading)

In my experience ( i do not know how dotnet scanner behaves) in the console you also get displayed an URL that points to your analyzed project … so not “only” https://localhost:9000 but https://localhost:9000/dashboard?id= etc

So … do you see - in the CLI console - an URL pointing to your analysis result?

Hi Daniel,

The localhost:9000 is not reloading by itself. I tried to manuallyy refresh it but since the analysis was done but not “communicated” to the CLI, it was like nothing was done and I was asked to run the analysis again.

So, I’m kinda stuck and have to re-do this over and over:

and in here:

thank you for clarifying!

if i understand it correctly i assume the following (which will not solve your troubles, but maybe help you better understand the flow)

  • you have a sq-server instance running at localhost:9000
  • you have started the sq-scanner process on the commandline (CLI)

What now happens is as follows (i hope i get it correct :sweat_smile: )

  • the CLI sq-scanner process performs the scan, creates an analysis result
  • the cli sq-scanner then tries to communicate (send) this result to the sq-server instance

i also realize that the dotnet scanning process seems to differ a bit from the java one or the plain cli scanner ( i am not used to “end” something in the CLI, for example)

so i guess you need help from someone who knows more about dotnet scanner :person_shrugging:

but maybe … if that is possible for you … it would help to attach a real logfile of the cli scan to this post


The sq-server is running in a docker instance:

My 1st choice was to run it using the zip file, install JDK 17 etc, but it didn’t work. So, running it using docker worked, the localhost:9000 can be reached etc.

so you found a solution? :thinking:

No. I’m stuck at the same point of the beginning.

it really might help to attach the CLI scanner logfile. i think it is also mentioned as one of the “helping comments” when you create a posting … to not make screenshots of logs, but instead put logfile here

i currently expect the dotnet scanner to behave a little different than the others i know a bit better … but: i’d expect to see in the logs a link to the scan-result … or something else if that is not possible

so, could you add the logfiles? either way, i might not be the most helpful replier up from now, as dotnet is not my forté :person_shrugging:

maybe it is possible to enhance verbosity of logging, too? -v something?