Sonarqube is not working in window 10

it is not working localhost:9000

here is startsonar cmd

wrapper | → Wrapper Started as Console
wrapper | Launching a JVM…
jvm 1 | Wrapper (Version 3.2.3)
jvm 1 | Copyright 1999-2006 Tanuki Software, Inc. All Rights Reserved.
jvm 1 |
jvm 1 | 2021.05.03 11:21:50 INFO app[o.s.a.AppFileSystem] Cleaning or creating temp directory C:\sonarqube-\temp
jvm 1 | 2021.05.03 11:21:50 INFO app[] Elasticsearch listening on [HTTP:, TCP:]
jvm 1 | 2021.05.03 11:21:50 INFO app[o.s.a.ProcessLauncherImpl] Launch process[[key=‘es’, ipcIndex=1, logFilenamePrefix=es]] from [C:\sonarqube-\elasticsearch]: C:\Program Files\Java\jdk-11.0.11\bin\java -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly\sonarqube-\temp -XX:ErrorFile=…/logs/es_hs_err_pid%p.log -Des.networkaddress.cache.ttl=60 -Des.networkaddress.cache.negative.ttl=10 -XX:+AlwaysPreTouch -Xss1m -Djava.awt.headless=true -Dfile.encoding=UTF-8 -Djna.nosys=true -XX:-OmitStackTraceInFastThrow -Dio.netty.noUnsafe=true -Dio.netty.noKeySetOptimization=true -Dio.netty.recycler.maxCapacityPerThread=0 -Dio.netty.allocator.numDirectArenas=0 -Dlog4j.shutdownHookEnabled=false -Dlog4j2.disable.jmx=true -Djava.locale.providers=COMPAT -Des.enforce.bootstrap.checks=true -Xmx512m -Xms512m -XX:MaxDirectMemorySize=256m -XX:+HeapDumpOnOutOfMemoryError -Delasticsearch -Des.path.home=C:\sonarqube-\elasticsearch -Des.path.conf=C:\sonarqube-\temp\conf\es -cp lib/* org.elasticsearch.bootstrap.Elasticsearch
jvm 1 | 2021.05.03 11:21:50 INFO app[o.s.a.SchedulerImpl] Waiting for Elasticsearch to be up and running
jvm 1 | Java HotSpot™ 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
jvm 1 | 2021.05.03 11:21:52 INFO app[o.s.a.SchedulerImpl] Process[es] is up
jvm 1 | 2021.05.03 11:21:52 INFO app[o.s.a.ProcessLauncherImpl] Launch process[[key=‘web’, ipcIndex=2, logFilenamePrefix=web]] from [C:\sonarqube-]: C:\Program Files\Java\jdk-11.0.11\bin\java -Djava.awt.headless=true -Dfile.encoding=UTF-8\sonarqube-\temp -XX:-OmitStackTraceInFastThrow --add-opens=java.base/java.util=ALL-UNNAMED --add-opens=java.base/java.lang=ALL-UNNAMED --add-opens=java.base/ --add-opens=java.rmi/sun.rmi.transport=ALL-UNNAMED -Xmx512m -Xms128m -XX:+HeapDumpOnOutOfMemoryError -server -Dhttp.nonProxyHosts=localhost|127.|[::1] -cp ./lib/common/;C:\sonarqube-\lib\jdbc\postgresql\postgresql-42.2.19.jar C:\sonarqube-\temp\sq-process5487539897032843215properties
jvm 1 | uncaught exception in thread [main]
jvm 1 | java.lang.IllegalStateException: failed to obtain node locks, tried [[C:\sonarqube-\data\es7]] with lock id [0]; maybe these locations are not writable or multiple nodes were started without increasing [node.max_local_storage_nodes] (was [1])?
jvm 1 | at org.elasticsearch.env.NodeEnvironment.(
jvm 1 | at org.elasticsearch.node.Node.(
jvm 1 | at org.elasticsearch.node.Node.(
jvm 1 | at org.elasticsearch.bootstrap.Bootstrap$5.(
jvm 1 | at org.elasticsearch.bootstrap.Bootstrap.setup(
jvm 1 | at org.elasticsearch.bootstrap.Bootstrap.init(
jvm 1 | at org.elasticsearch.bootstrap.Elasticsearch.init(
jvm 1 | at org.elasticsearch.bootstrap.Elasticsearch.execute(
jvm 1 | at org.elasticsearch.cli.EnvironmentAwareCommand.execute(
jvm 1 | at org.elasticsearch.cli.Command.mainWithoutErrorHandling(
jvm 1 | at org.elasticsearch.cli.Command.main(
jvm 1 | at org.elasticsearch.bootstrap.Elasticsearch.main(
jvm 1 | at org.elasticsearch.bootstrap.Elasticsearch.main(
jvm 1 | For complete error details, refer to the log at C:\sonarqube-\logs\sonarqube.log
jvm 1 | 2021.05.03 11:22:03 WARN app[o.s.a.p.AbstractManagedProcess] Process exited with exit value [es]: 1
jvm 1 | 2021.05.03 11:22:03 INFO app[o.s.a.SchedulerImpl] Process[es] is stopped

Hi @Charanjeet_Singh ,

welcome to the community :wave:

looks like there is still a lock on the elasticsearch data directory. can you make sure that there is no other sonarqube instance running and that the user that starts sonarqube is able to write to this location? if you already have checked all, you can delete this folder as the elasticsearch data will be recreated from the database if missing.

thanks solved

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.